Steyr Club Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi Everybody!
Most recently I bought Steyr SBS Pro Hunter in 30-06. Rifle came in as new condition inside factory box with all original packaging and looked like has never been fired, except maybe test fired in factory. Ordered Talley base and installed it. Put a scope on it and planned to go to the range to sight it in. Before I go I wanted to check again everything and now I can't remove the bolt! Simply second safety position with popping up grey bubble does not engage! It did work as it should when it arrived and I cleaned it many times over and put back together without problem. Now it doesn't. Any idea what happened? How to fix it?
I do have a Steyr Scout in .308, which has the very same SBS safety system as in Pro Hunter. At Scout everything is working as it should. One of the reasons to buy the Pro Hunter was exactly the SBS system I already knew. Also I liked the 1/2" spacers on butstock, allowing adjustments of LOP when wearing thick clothing during the winter. And maybe the best one was the excellent acuracy and grouping Scout has giving me every time.
Any suggestion will be appreciated. Thanks in advance!
 

·
Registered
Joined
·
803 Posts
Try pushing the bolt handle down to the Full lock . Then disengage the SBS tab. Sometimes they get hung in between.
If you like feel free to dm me tomorrow afternoon and I will try to help over the phone if you're in the USA.
Case at TnSteyr
 
1 - 2 of 2 Posts
Top