M9A1 Slide/magazine lock up issue.

Discussion in 'M, C, L and S Series' started by Onemoonh, Apr 29, 2013.

  1. Onemoonh

    Onemoonh New Member

    5
    0
    1
    Recently purchased a Steyr M9A1 new, have put around 200 rounds through it so far so I am not sure if this could be a break in issue.

    What is happening is when I have an empty magazine in my M9 and have the slide locked back, if press the slide release it will only move forward slightly and will hear a "click". It will not close all the way.

    If I then try and release the magazine the button feels very "hard" and will not drop or release. The only way I can release the magazine is by pushing the magazine button hard and pull on the magazine pretty hard.

    I then hear a click like something has been "Cleared" and the slide will slam shut. I am not too sure what is happening or causing this so any help will be appreciated.

    If need be I can take a video to better demonstrate what is happening.

    Thanks
     
  2. JMJNet

    JMJNet Member

    57
    0
    6
    Welcome!!

    It happened to mine with new empty 17rds mags.

    All I did was keep racking it a few times (release the slide catch and let it slam) till it clears up the empty magazine and go without any hang up.
    When I look at the magazine, it took out a very little piece of the follower.

    There is also another issue that member has posted here about it not going all the way, something to do with the striker pin.
    You can search those, there is not too much post here so you can probably find it very easy.
    I don't have this particular issue.

    For the mag release, I just exercise the release with new magazine a lot of time till it smooth.
    I did it with all new mags purchased also.

    Not sure if this will solve your problem but I read it here somewhere that it is part of the break-in.

    Of course, if it does not solve your issue, you can always call to SAI and send them in.
     

  3. Onemoonh

    Onemoonh New Member

    5
    0
    1
    Ah thanks for the info I will try what you mentioned. So it seems the issue might actually be with the magazine itself and not the firearm, interesting.


     
  4. JMJNet

    JMJNet Member

    57
    0
    6
    Yes, at least that was what happened on mine.
     
  5. Onemoonh

    Onemoonh New Member

    5
    0
    1
    Fired some more rounds through it and did what you suggested, working like a charm now!
     
  6. JMJNet

    JMJNet Member

    57
    0
    6
    Cool!!! Just break-in issue.