Flying Extractor

Discussion in 'M, C, L and S Series' started by WeedNemesis, Apr 27, 2005.

  1. WeedNemesis

    WeedNemesis New Member

    12
    0
    0
    Hey everyone, got my new mags today and decided to hand cycle a few rounds through to make sure there weren't any problems. Well on the second round my M9 ejected the bullet & the extractor. Fortunately, I found the extractor, spring, and plunger. My question is has anyone else experienced this phenomenon? I cleaned the extractor once, shot 100 rounds, cleaned again and now this. Really quite strange.
     
  2. FlaChef

    FlaChef Guest

    new one on me, sent my spring flying into the ether once, but that was because i was reassembling it in a rush.

    did you maybe not have it seated all the way last time you reassembled, or have the pin rotated the wrong way?
     

  3. Deluxe247

    Deluxe247 Supporting Member

    2,497
    2
    0
    What Chef said... Make sure you double check everything when re-asembling. It might just not have been seated correctly the last time you cleaned it. Have you shot it since the last time you took it apart or is this the first time you cycled rounds through it since cleaning?

    -D
     
  4. ministerofdeath

    ministerofdeath New Member

    925
    0
    0
    I concur with the above, either they are correct or you have a serious flaw that happened during production to your individual Steyr.
     
  5. WeedNemesis

    WeedNemesis New Member

    12
    0
    0
    I was pretty sure I had the plunger turned right and that it was seated properly. Like I said originally I had removed it once, reassembled, shot 100 rounds, removed & reassembled, then cycled the 2 rounds. It's just really strange cause I put it back together after it went flying and cycled ~60 rounds through without any further trouble. I've also shot ~600 rounds before the first cleaning without any trouble, just having my head pelted with shells.