Steyr Club Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi Folks,

I purchased a brand new Steyr S40a1 last week and put 100 rounds through it, had one major FTE: What happened was I pressed the trigger, nothing happened, so I waited for a bit, then the RO and I tried to rack the slide to get the round out. Eventually with some force the CRO got the round to come out. Sure enough, light primer strike. The pistol had gone out of battery just enough to cause this malfunction. When I called Steyr they blamed the Remington UMC ammo I used. Also said it’s the break in period so wait a while and shoot some more.

This normal?

My deep concern for this pistol is the slightest touch of the slide puts the gun out of battery and effectively out of commission. Don’t want to CCW with this puppy until I’m confident she’s gonna be ready if and when i need it.

Any thoughts???

Thx!!
 

·
Registered
Joined
·
31 Posts
I would keep putting a variety of ammo down range with it. I have not had any malfunctions with my m9a1 . I have shoot roughly 200 rds of UMC in mine and had no issues. I shoot sellior and bellot, aguila, blazer brass, speer lawman, wwb, american eagle and all worked well. I would also make sure you do a full strip of the gun, making sure the firing pin is dry without any lube on it. I have also never had any ejection problems, i also remove it and clean it after long range sessions. The fire control unit is also easy to remove and clean, just make sure to not lose any springs. I would try different ammo if you believe the UMC is a problem.
 

·
Registered
Joined
·
113 Posts
Hi Folks,

I purchased a brand new Steyr S40a1 last week and put 100 rounds through it, had one major FTE: What happened was I pressed the trigger, nothing happened, so I waited for a bit, then the RO and I tried to rack the slide to get the round out. Eventually with some force the CRO got the round to come out. Sure enough, light primer strike. The pistol had gone out of battery just enough to cause this malfunction. When I called Steyr they blamed the Remington UMC ammo I used. Also said it’s the break in period so wait a while and shoot some more.

This normal?

My deep concern for this pistol is the slightest touch of the slide puts the gun out of battery and effectively out of commission. Don’t want to CCW with this puppy until I’m confident she’s gonna be ready if and when i need it.

Any thoughts???

Thx!!
I had this same issue, I have a M40A1. First, you need to fire about 300-500 rounds to break in a pistol properly if you plan on carrying it. Then you must test your carry ammo, at least 50-100 rounds, more is better. If it doesn't cycle properly pick a different carry ammo. It's quite possible the ammo wasn't sized properly, it happens. I've heard this complaint about UMC ammo before. You say the slightest touch puts the pistol out of battery - does that mean the trigger won't fire? I had this same issue for awhile but eventually after about 500 rounds it went away. I can't make it go out of battery anymore either - in the beginning I could by slightly pushing the slide back but that's gone now. Just keep shooting it, I bet everything works out fine.
 
1 - 4 of 4 Posts
Top